Uploaded by User69426

Modul Maple

advertisement
MODUL MAPLE
Oleh:
Bagus Juliyanto, S.Si, M.Si
Buku Panduan untuk Pelatihan Komputasi
Jurusan Matematika
Fakultas Matematika dan Ilmu Pengetahuan Alam
Universitas Jember
Oktober 2020
1. PENDAHULUAN
1.1 Apa itu Maple?
Maple merupakan program komputer yang dikembangkan oleh Grup Symbolic
Computation di University of Waterloo Ontario, Kanada pertama kali pada tahun 1980 untuk
keperluan bidang matematika, statistika dan komputasi aljabar.
Maple adalah suatu program interaktif yang mengintegrasikan kemampuan komputasi
baik numerik ataupun simbolik, visualisasi (grafik) dan pemrograman. Dengan Maple, kita dapat
membuat dokumen interaktif untuk menyelesaikan persoalan-persoalan matematika dengan
ekspresi Matematika. Kita juga dapat menggabungkan “text” dan ekspresi matematika di baris
yang sama, menambahkan tabel untuk mengatur isi dari pekerjaan Anda, atau menyisipkan
gambar, sketsa daerah, dan spreadsheet. Kita dapat memvisualisasikan dan menganimasikan dalam
dua dan tiga dimensi, format teks untuk makalah akademis atau buku, dan masukkan hyperlink ke
file Maple, atau alamat email.
.
1.2 Cara Memulai Maple
Untuk menjalankan Maple ada dua cara yang dapat digunakan yaitu :
1.
Mengklik dua kali icon Maple pada desktop seperti gambar berikut
2.
Melalui tombol start pada window, masuk ke menu program dan klik submenu Maple.
Kalau sudah di launch, maka akan keluar Window Maple. Seperti pada gambar dibawah ini :
2
Pada tampilan awal MAPLE, terlihat beberapa jendela yang merupakan bagian penting di dalam
MAPLE, antara lain :
Jendela perintah (Worksheet)
Pada Worksheet, semua perintah maple dituliskan dan diekskusi. Kita dapat menuliskan
perintah perhitungan sederhana, memanggil fungsi, mencari informasi tentang sebuah fungsi
dengan aturan penulisannya (help), demo program, dan sebagainya. Setiap penulisan perintah
selalu diawali dengan prompt ‘[ >’, dan diakhiri dengan perintah tanpa tanda baca atau dengan
semicolon (;), bila akan segera ingin mengetahui hasil operasi Maple atau perintah diakhiri
dengan colon (:) bila hasilnya tidak ingin ditampilkan tapi tetap diproses. Selanjutnya tekan
[Enter]. Sebaiknya sebelum perintah-perintah diberikan pada maple, dimulai dahulu dengan
perintah [ > restart ; untuk pengosongan memori.
1.3 Package dan Permintaan Bantuan
Package merupakan paket Maple yang digunakan untuk menjalankan/merunning suatu
perintah/ekpresi khusus. Contoh dari Package dalam Maple antara lain plots, geometry, geom3d,
LinearAlgebra,
GroupTheory,
DEtolls.
Penulisan
package
dalam
Maple
adalah
“with(package):”
Jika kita mengalami kesulitan dalam Maple, kita dapat mencari bantuan di Maple
dengan dua cara, yaitu : (1) masuk ke menu Help  Maple Help dan (2) dengan menuliskan “
? keyword “ di worksheet.
3
2. OPERATOR MATEMATIKA dalam MAPLE
2.1 Operasi, Fungsi, dan Perintah Dasar dalam Maple
Operasi aritmaika dasar dalam Maple memiliki perintah yang sama dengan operasi dasar
dalam matematika pada umumnya. Setiap kita menulis operasi dasar, maka seketika itu juga kita
bisa melihat hasil dari operasi tersebut yang dirangkum dalam tabel berikut:
No Operasi
Fungsi
Terlihat di Maple
1
+
Penjumlahan
2
-
Pengurangan
3
/
Pembagian
4
*
Perkalian
5
sqrt
akar
6
^
pangkat
Beberapa fungsi umum seperti exponensial, trigonometri, hiperbolik dll yang dapat
dipakai dalam Maple dapat diringkas dalam penjelasan berikut
No
Fungsi
Perintah di Maple
1
Eksponensial
2
Logaritma bilangan dasar e
ln(x) atau log(x)
3
Logaritma bilangan dasar a
log[b](a) atau logb(a)
4
Trigonometri
5
Invers trigonometri
6
Fungsi hiperbolik
7
Invers fungsi hiperbolik
8
radian
hasil di Maple
exp(x)
ln(x)
sin(x), cos(x), tan(x),
cot(x), sec(x), csc(x)
arcsin(x), arcos(x)
dan lainnya
sinh(x), cosh(x) dan
lainnya
arcsinh(x),
arccosh(x)
dan lainnya
Pi
Catatan : Semua sudut digunakan satuan radian, Contoh seperti gambar berikut:
4
Beberapa perintah dasar dalam Maple yang sering digunakan adalah sebagai berikut:
No
Perintah di Maple
Makna
1
abs(x)
absolut
2
3
4
infinity
!
(I)2
Ketakhinggaan
Faktorial
5
evalf[n](x)
Contoh/hasil di Maple
3!
-1
i=√−1
Mengkonversi bilangan pecahan
menjadi bilangan desimal sampai n
bilangan dibelakang koma.
merupakan perintah untuk menghitung
bentuk aljabar yang ditujukan pada
variabel tertentu
6
eval
7
solve
Menyelesaikan persamaan atau
pertidaksamaan
8
fsolve
Menyelesaikan permasalahan
matematika dengan memberikan hasil
numerik
9
a mod b
10
subs
0.2857142857
Modulo
Substitusi variable tertentu
2.2 Text mode vs Math Mode
Software Maple memberikan fasilitas berupa Math mode dan text mode. Math Mode
adalah mode dimana setiap perintah yang kita ketik akan dievaluasi secara otomatis oleh Maple
sebagai perintah matematika yang memerlukan hasil perhitungan. Ketika kita membuka Maple,
secara default Maple sudah dalam Math mode ditandai dengan kursor masukan perintah dalam
keadaan miring dan setelah di tekan Enter Hasilnya akan diberikan suatu nomor persamaan.
Sedangkan Text mode adalah mode dimana setiap perintah kita akan ditulis seperti pada
word processor. Ciri yang paling mencolok dari text mode adalah huruf yang tertulis merupakan
huruf tegak seperti pada word processor.
5
Untuk mengubah mode dalam Maple, bisa kita klik bagian seperti pada gambar berikut:
Berikut contoh hasil perbandingan Text Mode dan math Mode:
2.3 Labelling persamaan
Labelling adalah pelabelan persamaan dalam Maple. Ketika kita membuka Maple, secara
default mode math akan menyala. Sehingga setiap yang kita tulis dan setelah itu kita tekan enter,
maka secara otomatis diruas kanan akan muncul nomer persamaan yang sesuai dengan urutan
penekanan enter.
Pada pelabelan persamaan, disamping kita bisa memanggil label dari persamaan tersebut,
kita juga bisa mengganti format label yang sudah default (berupa nomor) dari maple.
6
Berikut gambar contoh hasil dari pemanggilan label persaman yang kemudian
diintegralkan.
Cara untuk memanggil label yaitu dari menu Insert  label, atau dengan shortcut CTRL+L
seperti gambar berikut:
Berikut gambar cara memangggil label persamaan
7
Mengkonversi ke Label Referensi
Pada workspace, jika kita mengetik suatu angka dari persamaan maka angka tersebut tidak bisa
langsung dikenali sebagai suatu label persamaan. Agar tulisan kita dikenali sebagai label, maka
kita bisa lakukan dengan mengkonversi ke dalam label dengan cara sebagai berikut:
1. Misalnya, Ketik angka 4. Kemudian pilih menu FormatConvert to label reference
2. Maka angka 4 secara otomatis akan menjadi angka 4 dalam kurung dengan bentuk Bold ((4))
3. Tekan enter, maka akan memanggil label persamaan no 4.
Selanjutnya, untuk mengubah format label sesuai dengan yang kita inginkan maka bisa
kita lakukan dengan langkah-langkah berikut:
1. Pilih menu format  Equations label  label display  format label  Label
Numbering Scheme
2. Atur format sesuai yang kita inginkan
8
2.4 Manipulasi Polinomial
Ada beberapa perintah penting yang biasanya digunakan dalam maple diantaranya yaitu:
1
2
3
4
5
6
Perintah
Maple
simplify
expand
factor
solve
fsolve
evalf
7
8
coeffs
coeff
9
10
11
degree
ldegree
roots
No
Tujuannya
Menyederhanakan expresi aljabar
Menguraikan suatu expresi
Memfaktorkan suatu expresi
Menyelesaikan sistem persamaan dalam bentuk aljabar
Memberikan solusi numerik riil
Merupakan suatu perintah yang untuk mencari hasil akhir yang lebih spesifik
dan dalam bentuk desimal.
Untuk menampilkan semua koefisien polynomial secara terurut
Untuk menampilkan koefisien variabel tertentu. Diakhir polinom harus
ditambahkan (dengan koma) variable yang akan ditetukan koefisiennya
Untuk menentukan derajat tertinggi polinomial
Untuk menentukan derajat terendah polinomial
Untuk mencari akar dan jumlah dar masing masing akar
9
Contoh:
Contoh penggunaan “evalf”
10
Contoh penggunaan “roots”
2.5 Plot Grafik Fungsi
Maple dapat menghasilkan berbagai macam plot suatu grafik dalam menggambarkan suatu
konsep yang sulit. Dalam menggambar grafik pada maple, bergantung pada dimensi dari
persamaan yang kita aplikasikan. Misal 1 dimensi, 2 Dimensi, 3 Dimensi, animasi dll. Maple juga
memberikan beberapa pilihan dalam customize grafik yang kita buat seperti judul plot, warna, axis
dll.
Maple menawarkan beberapa metode yang mudah dalam menggambar grafik dengan plot.
Metode tersebut antara lain:
1. The Interactive Plot Builder
2. Command atau perintah plotting
a. The Interactive Plot Builder
The Interactive Plot Builder adalah suatu interface pada maple yang berfungsi untuk
menggambarkan grafik. Beberapa tipe plotting yang tersedia dalam interface plot builder
diantaranya yaitu interaktif plot, animasi, interaktif animasi dan beberapa tipe lain sesuai
dengan kehendak kita seperti:
 2-D/3-D plot
 2-D polar
 2-D/3-D conformal plot dari fungsi kompleks
 2-D/3-D plot yang kompleks
 2-D implisit plot
 2-D vektor gradient
Cara menjalankan The Interactive Plot Builder: Pilih tools  assistants  plot Builder
11
Tampilan The Interactive Plot Builder
User Interace The Interactive Plot Builder
User Interace penambahan fungsi
12
Tentukan jendela Expressions - Tambahkan,
mengedit, atau menghapus ekspresi dan variabel.
Setelah selesai Anda dapat maju ke Pilih Plot
Jenis jendela
Interface untuk Tambahkan atau mengedit fungsi
User Interace pemilihan tipe plotting
User Interace Plot Options
Interface untu memilih jenis plot
Interface untuk Setting plot
13
Contoh:
1. Plot 1 Variabel
a. Tambahkan fungsi, Misal sin(x)/x klik accept
b. Klik OK lanjutkan Select Plot Type  plot tipe
2D-trigonometric plot  OK
2. Plot Banyak Ekspresi Dalam 1 Variabel
a. Tambahkan banyak fungsi satu persatu, Misal
sin(x)/x, cos (x) dan x2+4 klik accept
b. Klik OK lanjutkan Select Plot Type  plot tipe 2Dtrigonometric plot  option pilih warna sesuai
kehendak  OK
3. Plot Ekspresi Multivariate
a. Tambahkan
banyak
fungsi,
Misal
(1+sin(x*y))/(x^2+y^2) klik accept
b. Klik OK lanjutkan Select Plot Type  plot tipe 3D
plot   OK
4. Conformal Plot
a. Tambahkan banyak fungsi, Misal z3 klik accept
b. Klik OK lanjutkan Select Plot Type  plot tipe 2D Conformal plot atau 3D
conformal plot  plot
14
5. Plot Dalam Koordinat Polar
a. Tambahkan banyak fungsi, Misal 1+4*cos(4*theta) klik accept
b. Klik OK lanjutkan Select Plot Type  plot tipe 2D polar plot  plot
6. Interaktif Plotting
a. Tambahkan banyak fungsi, Misal x+3*sin(x*t) klik accept
b. Klik OK lanjutkan Select Plot Type  plot tipe Interactive Plot with 1 parameter
15
c. Atur range dari parameter t
d. Klik Plot untuk membuka hasil interactive plot
b. Command Atau Perintah Plotting
Maple merupakan software yang powerfull untuk masalah plot gambar. Terdapat berbagaii
cara dan macam plotting grafik, maupun data baik dalam 2D maupun 3D. Maple mempu
menggambar suatu fungsi satu dimensi, dua dimensi atau tiga dimensi dengan beberapa fasilitas
operasi yang lain. Untuk dapat menggunakan perintah-perintah pengeplotan ini, terlebih dahulu
harus memanggil perintah “with(plots);”. berikut adalah macam plot dalam 2D maupun 3D.
Sumber referensi:
http://www.maplesoft.com/support/help/maple/view.aspx?path=worksheet/reference/PlottingGui
de
16
2-D Plots
3-D Plots
Specialized Plots
Line Plots
Filled Plots
Vector and Grid Plots
Point Plots
Bar Plots
Mathematical Concepts
Calculated
Line Plots
Filled Plots
Vector and Grid Plots
Mathematical Concepts
Calculated
Statistical and
Financial Plots
Dynamic Systems
Text
More
Information
Plot Options
Interactive
Plotting
Combining Plots
Animating Plots
Transforming
Plots
Exporting Plots
2D Plot – Plot garis
2D plot - Plot Vector
17
Contoh Plot vector:
PlotVector(v, opts)
Parameters
v
opts -
Vector or list(Vector); specify which Vector(s) to plot
(optional) plot options
Download :
http://www.maplesoft.com/support/help/maple/view.aspx?path=VectorCalculus%2fPlotVector
18
Plot Option
Dalam plot juga ada beberapa pilihan atau option yang harus diperhatikan yaitu diantaranya
adalah
Color : Pilihan ini berfungsi untuk menentukan warda dari grafik yang akan ditampilkan.
Dan dalam pemilihan ini penulisannya berdasarkan ejaan bahasa inggris.
Misalnya ingin membuat grafik maka warna yang dituliskan adalah “red” jika
menginginkan warna biru maka dapat menggunakan atau mengetik kata “blue”
dan lain-lain.
Style : Style merupakan suatu pilihan untuk menentukan bentuk dari gambar atau garafik
ayang akan kita buat. Dalam stile ini ada dua macam yaitu “point” atau “line”.
Point di sini artinya adalah 8 bahwa grafik yang dibentuk berupa point atau titiktitik yang membentuk suatu garis atau kurfa. Sedangkan line yaitu garis atau
kurfa yang akan dibuar berbentuk gasis.
Title : Agar dapar membedakan antara gambar satu dengan gambar yang lain maka
masing-masing gambar dadat diberi mana sesuai dengan keperluanya melewati
option labels.
Linestyle : Linestyle merupaka suatu option yang digunakan untuk menentukan daereah
mana yang akan digambar atau biasanya disebut dengan barasan- batasan
suatu daerah
Labels : Labels berfungsi sebagai nama dari dua hal yang akan dihubungkan biasanya untuk
manamakan label pada sumbu x dan sumbu y.
2D-Point Plot
pointplot(L, options)
pointplot(A, options)
pointplot(v1, v2, options)
19
Parameters
L
-
set or list of two-dimensional points
A
-
n by 2 Matrix, where n is any positive integer
v1, v2
-
Vectors of the same length
options
- (optional) equations of the form option=value, where option is any of the
available plot options or one of connect, symbol, or color
20
3D Plot
Contoh:
DrawGraph(G)
DrawGraph(G, style=s)
DrawGraph(G, style=tree, root=v)
DrawGraph(G, dimension=d)
DrawGraph(G, style=spring)
DrawGraph(G, style=spring, redraw)
DrawGraph(G, style=spring[constant])
DrawGraph(L, options)
Parameters
G- graph
s - (optional) circle, tree, bipartite, spring, planar
v - (optional) name of the root vertex
d - (optional) integer 2 or 3
L - list or set of graphs
Terlebih dahulu harus memanggil paket graf sebagai berikut:
>
>
>
21
22
Contoh 3D plot:
plot3d(expr, x=a..b, y=c..d, opts)
plot3d(f, a..b, c..d, opts)
plot3d([exprf, exprg, exprh], s=a..b, t=c..d, opts)
plot3d([f, g, h], a..b, c..d, opts)
Parameters
expr
f, g, h
exprf, exprg, exprh
a, b
c, d
x, y, s, t
opts
- expression in x and y
- procedures or operators
- expressions in s and t
- real constants, procedures, or expressions in y
- real constants, procedures, or expressions in x
- names
- (optional) equations of the form option=value where option is described in plot3d/opti
Download : http://www.maplesoft.com/support/help/maple/view.aspx?path=plot3d
>
>
23
Contoh
c1: cos  x   2 cos  0.4 y  , sin  x   2 sin  0.4 y  , y :
c2 : cos  x   2 cos  0.4 y  , sin  x   2sin  0.4 y  , y :
c3 : cos  x   2 sin  0.4 y  , sin  x   2 cos  0.4 y  , y :
c4 : cos  x   2sin  0.4 y  , sin  x   2 cos  0.4 y  , y :
plot3d c1, c2, c3, c4, x  0..2π, y  0..10, grid  25,15, color  sin  x   




Contoh:
plot3d 1.3x sin  y , x  1..2π, y  0..π, coords  spherical 






Animasi
Maple juga bisa digunakan untuk meng-animasi suatu objek grafik baik 2D maupun 3D Contoh
with(plots):
plots[animate]( plot, [sin(A*x), x=-Pi..Pi, thickness=2], A=1..5 );
24
Menggambar multi grafik dalam satu Diagram

x3 sin  x  
plot  x  ,
 , x  0..1, linestyle  dot, dash

3
x





25


2.6 Palettes and the power of right Click
Palettes
Palette adalah kumpulan tombol yang mewakili simbol ekspresi maupun operator yang
telah ditetapkan seperti operator dalam matematika, Matriks, dan Vektor. Dengan mengklik
tombol-tombol pada palette, Anda dapat membangun atau mengedit ekspresi matematika tanpa
harus mengingat sintaks perintah pada Maple. Maple menyediakan lebih dari 30 palette. Anda
dapat menggambar simbol dengan palet Handwriting dan biarkan Maple menyesuaikan dengan
simbol yang ada. Anda dapat membuat Favorit palette ekspresi dan entitas yang paling sering Anda
gunakan.
Contoh:
>
26
27
Palette yang
berisikan semua
ekspresi
matematika seperti
Integral, limit,
turunan dll
Palette yang
berguna untuk
membuat matriks
sesuai dengan
ukuran yang kita
inginkan
Palette yang
bersisikan symbol
yang umum
digunakan
Palette yang
bersisikan huruf
Yunani
28
The Power of Right Click
Kelebihan Maple yang lain yaitu, terdapat menu yang sangat lengkap pada klik kanan
pada setiap ekspresi matematis yang kita tunjuk untuk dilakukan eksekusi sesuai dengan menu
yang muncul tanpa harus menggunakan perintah command pada Worksheet/Workspace. Sebagai
contoh, kita bisa menghitung decimal dari 9/7 sampai 100 digit:
29
Menu pada klik Kanan yang Hasil Eksekusi beberapa perintah pada menu Klik kanan
muncul
30
3. Fungsi Dasar Matematika dalam Maple
3.1
Limit
Untuk menghitung limit, bisa dilakukan dengan dua cara yaitu dengan menggunakan
Palette atau dengan command pada workspace.
Berikut contoh dengan palette:
Berikut contoh dengan Command:
31
3.2
Derivatif atau Turunan
Untuk mencari turunan dari suatu fungsi, bisa menggunakan tools pada Palette,
Command pada worksheet maupun pada klik kanan yang muncul saat ursor pada fungsi yang
akan diturunkan.
Contoh
Turunan fungsi 1 variabel
Turunan Parsial
Turunan fungsi Implisit
32


implicitdiff  x ^ 2 y  3 y ^ 3 x  0, x, y  . = 
y  2x  3y 2 
x x  9 y2




x ^ 2 y 3 y ^3x  0




y  2x  3y 2 
x x  9 y2


3.3 Integral
Untuk mencari hasil Integral dari suatu fungsi, bisa menggunakan tools pada Palette,
Command pada worksheet maupun pada klik kanan yang muncul saat kursor pada fungsi yang
akan diintegralkan.
Contoh
Integral 1 variabel
33
Contoh Integral lipat 2
3.4
Deret
Deret Taylor
Untuk membangkitkan deret Taylor dari suatu fungsi adalah sebagai berikut:
taylor sin  x  , x  1
1
2
1
3
1
4
1
5
6
sin 1  cos 1 x 1  sin 1 x 1  cos 1 x 1  sin 1 x 1 
cos 1 x 1  O  x 1
2
6
24
120

Barisan deret Aritmatika dan Geometri
34

3.5
Persamaan Differensial
Persamaan diferensial adalah persamaan yang di dalamnya memuat diferensial. Persamaan
diferensial biasa (ordinary differensial equation/ODE) adalah persamaan diferensial dengan satu
variabel, misalnya y” + 5y’ + 6y = 0. Yang menjadi masalah dalam persamaan diferensial adalah
menentukan solusi dari persamaan diferensial. Solusi persamaan diferensial adalah suatu
persamaan yang memenuhi persamaan diferensial tersebut. Solusi dari persamaan diferensial di
atas adalah y = C1 e-3x + C2 e-2x dengan C1 dan C2 sebarang bilangan konstanta, karena bila
disubstitusikan persamaan ini memenuhi persamaan diferensial di atas. Solusi ini disebut solusi
umum. Dengan Maple solusi ini dapat diperoleh dengan perintah dsolve.
Bila nilai awal dari suatu persamaan diferensial diketahui, maka persamaan diferensial tadi
disebut masalah nilai awal. Solusi yang diperoleh dari masalah nilai awal disebut solusi khusus,
karena tidak lagi mengandung bilangan konstanta C.
dsolve(ODE)
dsolve(ODE, y(x), options)
dsolve({ODE, ICs}, y(x), options)
Parameters
ODE
- ordinary differential equation, or a set or list of ODEs
y(x)
- any indeterminate function of one variable, or a set or list of them,
representing the unknowns of the ODE problem
ICs
- initial conditions of the form y(a)=b, D(y)(c)=d, ..., where {a, b, c, d} are
constants with respect to the independent variable
options - (optional) depends on the type of ODE problem and method used, for
example, series or method=laplace. (See the Examples section.)
Contoh:
2
> ode : d y  x   2y  x  1
dx2





2
> dsolve ode 
d
ode : 2 y  x   2y  x  1
dx
y  x  e
2x
_ C2  e
2x
_ C1
1
2
Definisikan Nilai awal
> ics : y 0  1,D  y  0   0
> dsolve ode, ics
35
4. Geometri Rancang bangun
4.1 Konstruksi Objek pada Program Maple
Disajikan beberapa contoh konstruksi objek-objek geometri dengan software
Maple untuk mengkonstruksi objek geometri.
a. Penyajian Segmen Garis
Untuk membuat segmen garis menggunakan maple, dapat menggunakan
Persamaan:
x = (1 – t ) x1 + t x2,
y = (1 – t ) y1 + t y2,
z = (1 – t) z1 + t z2.
Misalkan akan dibuat suatu segmen garis a dengan titik-titik ujung A(0,0,0) dan
B(1,15,1). Berikut ini merupakan script program Maple.
a1:=spacecurve([(1-t)*0+t*0,(1-t)*0+t*15,(1t)*0+t*1],t=0..1):
b. Penyajian Bidang Segiempat
Misalkan dibangun bidang segiempat dengan titik sudut-titik sudut A(2,2,0),
B(0,2,0), C(2,0,3) dan D(0,0,3) maka bentuk perintahnya sebagai berikut.
a2:=plot3d([(1-v)*(2-2*u)+v*(2-2*u),(1-v)*2+v*0,(1v)*0+v*3],u=0..1,v=0..1):
36
c. Penyajian Permukaan Tidak Datar
Sama halnya dengan penyajian bidang segitiga dan segiempat, untuk membuat permukaan
tidak datar maka kurva batasnya dipilih yang menyilang satu sama lain. Dibuat bidang
atau permukaan tidak datar c dari titik-titik A(2,0,0), B(2,3,0), C(3,1,3) dan D(-1,5,3).
a3:=plot3d([(1-v)*2+v*(3-2*u),(1-v)*3*u+v*(1+4*u),(1-v)
*0+v*3],u=0..1,v=0..1):
d. Penyajian Bidang Lingkaran
Untuk membuat bidang lingkaran dengan memberikan nilai jari-jari dan titik
pusatnya. Misalkan akan dibentuk lingkaran e dengan pusat di A(0,0,0) dan jari-jari
sepanjang 3 satuan. Berikut ini contoh script-nya.
a4:=plot3d([r*3*cos(t)+0,r*3*sin(t)+0,0],r=0..1,t=0..2*Pi):
e. Penyajian Permukaan Selimut Silinder
Untuk membuat permukaan selimut silinder dengan memberikan nilai jari-jari, titik
pusat dan ketinggian silinder. Misalkan akan dibentuk silinder h dengan pusat di A(0,0,0),
jari-jari sepanjang 2 satuan dan ketinggian 6 satuan. Berikut ini contoh scrip-nya.
a5:=plot3d([2*cos(u)+0,2*sin(u)+0,2*v],u=0..2*Pi,v=1..3
,scaling=constrained,labels=([x,y,z]):
37
f. Penyajian Permukaan Bola
Untuk membuat permukaan bola dengan memberikan nilai jari-jari dan titik
pusat bola. Misalkan akan dibentuk bola dengan pusat di A(0,0,0) dan jari-jari sepanjang
3 satuan. Berikut ini contoh script.
a6:=plot3d([3*sin(v)*cos(u)+0,3*sin(v)*sin(u)+0,3*cos(v
)+0],u=0..2*Pi,v=0..Pi,scaling=constrained):
g. Penyajian interpolasi antara dua kurva
Misalkan akan menginterpolasi antara dua kurva yang diberi nama ll dengan
kurva pertama berupa setengah lingkaran berpusat di (0,0,0) sedangkan kurva kedua
berupa lingkaran berpusat di (0,5,0) dengan jari-jari masing-masing 2 satuan. Berikut ini
merupakan contoh script-nya:
ll:=plot3d([(1-v)*2*cos(t)+v*(2*cos(-t)),(1-v)*2*sin(t)+
v*(2*sin(-t)+5),0],v=0..1,t=0..Pi):
Permukaan hasil interpolasi ditunjukkan pada Gambar berikut.
h. Penyajian permukaan Bezier
Pada program Maple untuk membangun permukaan Bezier misalnya permukaan
Bezier g, dapat dituliskan contoh script program sebagai berikut.
b:=([4*(1-t)^2+5*2*(1-t)*t+t^2*0,0*(1-t)^2+0*2*(1t)*t+t^2*0,8*(1-t)^2+7*2*(1t)*t+t^2*7],t=0..1,color=red,thickness=5,labels=[x,y,z]
):
z5:=spacecurve(p):display(z5):
38
c:=plot3d([(6*(1-t)^2+3*2*(1-t)*t+t^2*6)*cos(v),(6*(1t)^2+3*2*(1-t)*t+t^2*6)*sin(v),(9*(1-t)^2+3*2*(1t)*t+t^2*3)],t=0..1,v=0..Pi,labels=[x,y,z],axes=normal,
scaling=constrained):
CONTOH HASIL DEFORMASI
A.1 Deformasi Prisma Segienam Efek Puntiran
> theta:=Pi/2: #sudut putar#
> tpunt1:=2*t: tpunt2:=1/2*t: #tinggi#
> rpunt:=25: #jarak tipus ke titik sudut#
for i from 0 to 5 do
> cp[2*i+1]:="Red": cp[2*i+2]:="Pink":
a1[i+1]:=plot3d([(1-v)*((1u)*rpunt*cos(Pi/3*i)+u*rpunt*cos(Pi/3*i+theta))+v*((1u)*rpunt*cos(Pi/3*(i+1))+u*rpunt*cos(Pi/3*(i+1)+theta)),(1-v)*((1u)*rpunt*sin(Pi/3*i)+u*rpunt*sin(Pi/3*i+theta))+v*((1u)*rpunt*sin(Pi/3*(i+1))+u*rpunt*sin(Pi/3*(i+1)+theta)),(1u)*tpunt1+u*tpunt2],u=0..1,v=0..1,color=cp[i+1]):
end do:
> puntiran:=display({a1[1],a1[2],a1[3],a1[4],a1[5],a1[6]}):
A.2 Deformasi Tabung Pola Tingkat
> restart:
> with(plots):
>
r=4, t=12
Nilai vp < r untuk lengkung cekung dan nilai vp > r untuk lengkung cembung
> vp:=6:
39
> x1:=(4*(1-t)^2+vp*2*(1-t)*t+4*t^2): y1:=(4*(1-t)^2+vp*2*(1-t)*t+4*t^2):
z1:=(2*(1-t)^2+6*2*(1-t)*t+10*t^2):
>
> P1:=plot3d([v*2*cos(u),v*2*sin(u),0],u=0..2*Pi,v=0..1,color="Green"):
> a1:=plot3d([2*cos(u),2*sin(u),v],u=0..2*Pi,v=0..1,color="Green"):
> P2:=plot3d([v*3*cos(u),v*3*sin(u),1],u=0..2*Pi,v=0..1,color="Yellow"):
> b1:=plot3d([3*cos(u),3*sin(u),v],u=0..2*Pi,v=1..2,color="Yellow"):
> P3:=plot3d([v*4*cos(u),v*4*sin(u),2],u=0..2*Pi,v=0..1,color="YellowGreen"):
> c1:=plot3d([x1*cos(v),y1*sin(v),z1],t=0..1,v=0..2*Pi,color="YellowGreen"):
> P4:=plot3d([v*4*cos(u),v*4*sin(u),10],u=0..2*Pi,v=0..1,color="YellowGreen"):
> d1:=plot3d([3*cos(u),3*sin(u),v],u=0..2*Pi,v=10..11,color="Yellow"):
> P5:=plot3d([v*3*cos(u),v*3*sin(u),11],u=0..2*Pi,v=0..1,color="Yellow"):
> e1:=plot3d([2*cos(u),2*sin(u),v],u=0..2*Pi,v=11..12,color="Green"):
> P6:=plot3d([v*2*cos(u),v*2*sin(u),12],u=0..2*Pi,v=0..1,color="Green"):
>
display([P1,a1,P2,b1,P3,c1,P4,d1,P5,e1,P6],style=patchnogrid,labels=[x,y,z],scaling=c
onstrained);
A.3 Deformasi Prisma Segienam Pola Gypsum
> #Sisi Datar Tegak#
> x1:=u*0+(1-u)*6:
y1:=u*0+(1-u)*0: z1:=u*0+(1-u)*0:
x2:=u*0+(1-u)*6:
y2:=u*0+(1-u)*0: z2:=u*6+(1-u)*6:
> #Sisi Datar Bawah#
> x3:=u*6+(1-u)*6:
y3:=u*0+(1-u)*6: z3:=u*0+(1-u)*0:
x4:=u*0+(1-u)*0:
y4:=u*0+(1-u)*6: z4:=u*0+(1-u)*0:
> #Bagian Samping#
> x5:=(6*(1-t)^2+6*2*(1-t)*t+6*t^2): y5:=(0*(1-t)^2+0*2*(1-t)*t+2*t^2):
z5:=(6*(1-t)^2+4*2*(1-t)*t+4*t^2):
x6:=(6*(1-t)^2+6*2*(1-t)*t+6*t^2): y6:=(2*(1-t)^2+4*2*(1-t)*t+4*t^2):
z6:=(4*(1-t)^2+4*2*(1-t)*t+2*t^2):
x7:=(6*(1-t)^2+6*2*(1-t)*t+6*t^2): y7:=(4*(1-t)^2+4*2*(1-t)*t+6*t^2):
z7:=(2*(1-t)^2+0*2*(1-t)*t+0*t^2):
x8:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2): y8:=(0*(1-t)^2+0*2*(1-t)*t+2*t^2):
z8:=(6*(1-t)^2+4*2*(1-t)*t+4*t^2):
40
x9:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2): y9:=(2*(1-t)^2+4*2*(1-t)*t+4*t^2):
z9:=(4*(1-t)^2+4*2*(1-t)*t+2*t^2):
x10:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2): y10:=(4*(1-t)^2+4*2*(1-t)*t+6*t^2):
z10:=(2*(1-t)^2+0*2*(1-t)*t+0*t^2):
>
x11:=(6*(1-t)^2+6*2*(1-t)*t+6*t^2): y11:=(0*(1-t)^2+1*2*(1-t)*t+2*t^2):
z11:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2):
x12:=(6*(1-t)^2+6*2*(1-t)*t+6*t^2): y12:=(2*(1-t)^2+3*2*(1-t)*t+4*t^2):
z12:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2):
x13:=(6*(1-t)^2+6*2*(1-t)*t+6*t^2): y13:=(4*(1-t)^2+5*2*(1-t)*t+6*t^2):
z13:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2):
x14:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2): y14:=(0*(1-t)^2+1*2*(1-t)*t+2*t^2):
z14:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2):
x15:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2): y15:=(2*(1-t)^2+3*2*(1-t)*t+4*t^2):
z15:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2):
x16:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2): y16:=(4*(1-t)^2+5*2*(1-t)*t+6*t^2):
z16:=(0*(1-t)^2+0*2*(1-t)*t+0*t^2):
>
> #Permukaan#
> a1:=plot3d([v*x1+(1-v)*x2,v*y1+(1-v)*y2,v*z1+(1v)*z2],u=0..1,v=0..1,color="MediumSpringGreen"): b1:=plot3d([v*x3+(1v)*x4,v*y3+(1-v)*y4,v*z3+(1-v)*z4],u=0..1,v=0..1,color="MediumSpringGreen"):
>
> c1:=plot3d([v*x5+(1-v)*x8,v*y5+(1-v)*y8,v*z5+(1v)*z8],t=0..1,v=0..1,color="DeepSkyBlue"):
d1:=plot3d([v*x6+(1-v)*x9,v*y6+(1-v)*y9,v*z6+(1v)*z9],t=0..1,v=0..1,color="GreenYellow"):
e1:=plot3d([v*x7+(1-v)*x10,v*y7+(1-v)*y10,v*z7+(1v)*z10],t=0..1,v=0..1,color="Green"):
>
> f1:=plot3d([v*x5+(1-v)*x11,v*y5+(1-v)*y11,v*z5+(1v)*z11],t=0..1,v=0..1,color="DeepSkyBlue"): g1:=plot3d([v*x6+(1v)*x12,v*y6+(1-v)*y12,v*z6+(1-v)*z12],t=0..1,v=0..1,color="GreenYellow"):
h1:=plot3d([v*x7+(1-v)*x13,v*y7+(1-v)*y13,v*z7+(1v)*z13],t=0..1,v=0..1,color="Green"):
>
> i1:=plot3d([v*x8+(1-v)*x14,v*y8+(1-v)*y14,v*z8+(1v)*z14],t=0..1,v=0..1,color="DeepSkyBlue"):
j1:=plot3d([v*x9+(1-v)*x15,v*y9+(1-v)*y15,v*z9+(1v)*z15],t=0..1,v=0..1,color="GreenYellow"):
k1:=plot3d([v*x10+(1-v)*x16,v*y10+(1-v)*y16,v*z10+(1v)*z16],t=0..1,v=0..1,color="Green"):
>
>
display([a1,b1,c1,d1,e1,f1,g1,h1,i1,j1,k1],style=patchnogrid,labels=[x,y,z],scaling=
constrained);
41
A.4 Deformasi Kerucut Pola Mangkuk
> restart:
> with(plots):
>
> x1:=((6)*((1-u)^3)+(20)*3*((1-u)^2)*u+(1)*3*(1u)*(u^2)+(12)*(u^3)): y1:=((6)*((1-u)^3)+(20)*3*((1u)^2)*u+(1)*3*(1-u)*(u^2)+(12)*(u^3)): z1:=((0)*((1u)^3)+(3)*3*((1-u)^2)*u+(10)*3*(1-u)*(u^2)+(20)*(u^3)):
>a1:=plot3d([x1*cos(v),y1*sin(v),z1],u=0..1,v=0..2*Pi,color=
"OliveDrab"):
>display(a1,style=patchnogrid,labels=[x,y,z],scaling=constra
ined);
42
Contoh Konstruksi Piala
Contoh Konstruksi Tiang Teras
43
4.2 Membangun permukaan dengan data barisan titik
Suatu permukaan bisa kita gambarkan dari suatu barisan titik-titik yang diplot menjadi
suatu permukaan objek 3D.
Membangkitkan Barisan titik
seq(f, i = m..n)
seq(f, i = m..n, step)
seq(f, i = 1..m, step)
seq(f, i = x)
seq(f, i in x)
seq(m .. n, step)
seq(x)
Parameters
f
i
m, n
x
step

-

seq i , i  1..5
any expression
name
numerical values
expression
(optional) numerical value


1, 2, 3, 4, 5
Menggambar permukaan dari barisan titik 3D dengan command “Surfdata”. Terlebih
dahulu membuat barisan titik dalam 3D pada level z=0 mulai dari (0,0,0) sampai (10,10,0) sebagai
berikut:
44
Kemudian kita membuat permukaan yang lain dengan tujuan akan membuat suatu kubus
berukuran 10x10x5 satuan dengan mendefinisikan masing-masing permukaan dengan suatu
barisan titik-titik.
45
Gabungan dari 6 permukaan maka kita bisa membuat suatu objek 3D berbentuk balok
berukuran 10x10x5 satuan sebagai berikut:
surfdata a1, a2, a3, a4, a5, a6, axes  frame, labels  x, y, z;
46
Membuat permukaan tabung berdiameter 7 dengan tinggi 11 satuan
>
>
Membuat objek berbentuk bola


 
 
  4*cos   j / n  * 2* Pi *sin  i / n  * 2* Pi  5, 






e : seq  seq  4*cos   j / n  * 2* Pi  *cos   i / n  * 2* Pi   5,, i  0..20  , j  0..20  :







    4*sin   j / n  * 2* Pi   20







  
surfdata e, axes  frame,labels  x, y, z;
47
Penggabungan objek yang sudah dibuat:
surfdata a1, a2, a3, a4, a5, a6, h, e, axes  frame, labels  x, y, z


Berikut contoh objek-objek gabungan yang bisa kita buat melalui gabungan kurva permukaan
dalam Maple.

48
5. Programming dengan Maple
Contoh Program Metode bagi dua dalam mencari akar riil suatu persamaan Nonlinear
49
a =
0.0000000, m =
0.3987213
iterasi =
2, akar
iterasi =
3, akar
iterasi =
4, akar
iterasi =
5, akar
iterasi =
6, akar
iterasi =
7, akar
iterasi =
8, akar
iterasi =
9, akar
iterasi =
10, akar
iterasi =
11, akar
iterasi =
12, akar
iterasi =
13, akar
iterasi =
14, akar
iterasi =
15, akar
iterasi =
16, akar
0.5000000, b =
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
0.7500000,
0.6250000,
0.5625000,
0.5937500,
0.6093750,
0.6015625,
0.6054688,
0.6035156,
0.6044922,
0.6049805,
0.6052246,
0.6053467,
0.6052856,
0.6052551,
0.6052704,
1.0000000, f(c) =
galat
galat
galat
galat
galat
galat
galat
galat
galat
galat
galat
galat
galat
galat
galat
=
=
=
=
=
=
=
=
=
=
=
=
=
=
=
1.0000000
0.2000000
0.1111111
0.0526316
0.0256410
0.0129870
0.0064516
0.0032362
0.0016155
0.0008071
0.0004034
0.0002017
0.0001008
0.0000504
0.0000252
50
iterasi
iterasi
iterasi
iterasi
iterasi
=
=
=
=
=
17,
18,
19,
20,
21,
akar
akar
akar
akar
akar
=
=
=
=
=
0.6052628,
0.6052666,
0.6052685,
0.6052675,
0.6052670,
galat
galat
galat
galat
galat
=
=
=
=
=
0.0000126
0.0000063
0.0000032
0.0000016
0.0000008
akar = 0.6052670476
Galat = 0.0000007879
f(m) = 0.0000003110
51
Download
Random flashcards
hardi

0 Cards oauth2_google_0810629b-edb6-401f-b28c-674c45d34d87

Rekening Agen Resmi De Nature Indonesia

9 Cards denaturerumahsehat

sport and healty

2 Cards Nova Aulia Rahman

Nomor Rekening Asli Agen De Nature Indonesia

2 Cards denaturerumahsehat

Secuplik Kuliner Sepanjang Danau Babakan

2 Cards oauth2_google_2e219703-8a29-4353-9cf2-b8dae956302e

Create flashcards